We identified the Microsoft change that cause DMARC failures for some M365 Customers and have documented a resolution in our help center.
We're resolving this issue - but please reach out to support@tessian.com if you have any questions
We identified the Microsoft change that cause DMARC failures for some M365 Customers and have documented a resolution in our help center.
We're resolving this issue - but please reach out to support@tessian.com if you have any questions
Resolved
We identified the Microsoft change that cause DMARC failures for some M365 Customers and have documented a resolution in our help center.
We're resolving this issue - but please reach out to support@tessian.com if you have any questions
Monitoring
We've identified a change Microsoft has made to how they honor DMARC failures for M365 Customers.
This may prompt Microsoft to reject emails that fail DMARC if you have the DMARC setting enabled in M365.
Please follow the instructions in our help center to prepare for the change accordingly
Investigating
We’ve identified that Microsoft have made a change to how they honor DMARC failures for M365 customers with their DMARC setting enabled - linked here
M365 Customers using both Tessian Inbound Gateway and a Third Party Email Gateway (e.g. Mimecast) may be seeing some external to internal emails being blocked by Microsoft due to DMARC failing.
We’re actively supporting an investigation with a Customer and Microsoft in finding a resolution and will update here with next steps.
Please get in touch with support@tessian.com if you think you might be impacted by this.